Campaign Sending Failure

Incident Report for Engage

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 14:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2025 - 13:38 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 27, 2025 - 13:25 UTC

Update

We are continuing to investigate this issue.
Posted Mar 27, 2025 - 12:33 UTC

Investigating

Users are experiencing an error when attempting to send campaigns.

Our team is actively investigating the root cause of this issue. We will provide further updates as we progress towards a resolution.
Posted Mar 27, 2025 - 12:15 UTC
This incident affected: Sinch Engage - Detailed Services (Campaigns).