Login Issue and Customer Page Accessibility - Sinch Engage

Incident Report for Engage

Resolved

The fix has been fully implemented and the service disruption related to the Cloudflare outage is now resolved. All systems have returned to normal operation.
Posted Nov 18, 2025 - 15:00 UTC

Monitoring

A fix has been implemented in response to the Cloudflare service interruption, and service recovery is underway. We are actively monitoring all systems to ensure full resolution.
Posted Nov 18, 2025 - 14:48 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 14:03 UTC

Identified

The root cause is linked to a widespread interruption of service at our third-party provider, Cloudflare. You can review the incident and its status directly on the Cloudflare status page: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 12:30 UTC

Investigating

We are aware of an issue where customers are unable to log in to Sinch Engage. Our investigation confirmed this was due to an external service provider incident.
Posted Nov 18, 2025 - 12:29 UTC
This incident affected: Sinch Engage.